Site Created With Microsoft FrontPage 

  1stcom's FrontPage Information Web 
FrontPage 98 Problem Solving

 

I've created a WebBot Save Results form but when I tested it with Netscape Navigator I got the message, "Repost Form Data?" Is there a way to fix this?
FrontPage 98 sometimes sticks a line of code into your HTML document which causes the problem. The line looks like this: <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">. It seems that for some reason this line causes pages in Netscape Navigator to automatically reload a second or two after they initially start loading. Normally this doesn't cause a problem, other than a quick flicker when the page is loading that is hardly noticeable. However, it does cause a problem when you're using a Save Results WebBot and a custom confirmation page. 

If you don't specify a custom confirmation page in the Save Results WebBot's settings you won't have this problem. However, if you want to use a custom confirmation page (you probably should - the default page is really ugly) you can fix the problem by removing the line from that page.

Removing the offending line is easy. 

     

  1. Choose Page Properties from the File menu.
  2. Click the Custom tab in the Page Properties dialog box.
  3. Find the offending line (as listed above) in the System Variables area.  Click on it, the click on the Remove button.
  4. Click OK.  That's all there is to it.
When you would remove this line with FrontPage 97, it would stick it back in whenever you opened the page again (without even asking you!).  You won't have this problem in FrontPage 98.

Click here to return to the table of contents page.